
Sibelius Techniques for Aleatoric music – Neil Radisch 

 

Below are a collection of techniques useful for creating aleatoric music in Sibelius. Some are less 

commonly used Sibelius features, while others are hacks to make Sibelius do something it wasn’t 

really designed to do. 

 

I’m a PC user, so all keyboard shortcuts are PC-centric. 

 

BARLINES 

 

1) Hiding/changing barline for an entire system 

 

Unlike many Sibelius elements which can be hidden using “Home->Hide or Show->Hide or 

Show” (Ctrl-Shft-H), barlines are hidden by changing the barline type. Select the barline then use 

“Notation->Barlines->Invisible” to make the barline invisible. This can be reversed by using 

“Notation->Barlines->Normal”. Doing this will affect the barline for an entire system. 

 

 



There are situations, however, where you may want to hide the barline just for a single staff. To 

do this, you first have to create a new version of the instrument assigned to the staff. The 

instrument should be identical in every way except without barlines. In the above example, the 

second staff is “Violin II”. We will create “Violin IIhb” which is identical but has hidden 

barlines. 

 

a) Open the “Home->Instruments” dialog. 

 

 
 

b) Find the instrument that is currently attached to the staff. In this case I selected “Ensembles-

>Orchestral Instruments” then “Families in ensemble->Strings” then “Instruments in Family-

>Violin II”. 

 

c) Select “New Instrument…”. You will be asked if you want to create a new instrument based 

on “Violin II”. Respond yes. You will then see the “New Instrument” dialog. 

 



 
 

d) Change the “Name in dialogs” field to “Violin IIhb” (or whatever you want). This is the name 

that will appear in future dialogs. Leave the other “Name” fields as they are. 

 

e) In the “Notations Options” area of the dialog, select “Edit Staff Type…”. You will now see 

the “Staff Type” dialog. 

 



 
 

f) In the “Barlines” area of the dialog, deselect “Barlines”. Then hit “Ok”. 

 

g) Hit “Ok” on the “New Instrument” dialog, but leave the “Edit Instruments” dialog up. 

 

h) Find the new “Violin IIhb” instrument in the “Instruments not in family” area of the “Edit 

Instruments” dialog. Select it and hit the “Add to Family” button. 

 

You now have a “Violin II” instrument that does not have barlines. This instrument can be used 

wherever you want invisible barlines, and it will not affect the other instruments in the system. 

Use the “Home->Change” command to change instruments. 

 

If we start with this: 

 



 
 

Then we select the bars around which we do not want barlines. 

 

 
 

Execute the command “Home->(Instruments)Change”. You will see the “Instrument Change” 

dialog. Find the “Violin IIhb” previously created and select it. You’ll now see something messy 

like this on the screen. 

 

 



Select the unwanted text elements and hide them via “Home->Hide or Show->Hide or Show” 

(Ctrl-Shift-H). The text will disappear leaving this. 

 

 
 

Note that the second violin bar is missing it’s barline in the area we highlighted. You may still 

see the hidden elements in light gray. By default Sibelius will gray out hidden elements instead 

of hiding them so you can still click them. It does not affect printing. You can see a more 

WYSIWYG representation by deselecting “View->(Invisibles)Hidden Objects”. 

 

The same technique, using the built in “no instrument (hidden)” lets you create cut-away scores. 

 
 

NOTE STEMS 

 

1) Hiding note stems 

 

Select the notes, then “Notations->(Noteheads)Type->Stemless” (Alt-Shift-8) 



                       
 

2) Hiding note heads 

 

Select the notes, then “Notations->(Noteheads)Type->Headless” (Alt-Shift-7) 

 

                       
 

3) Moving and angling note beams 

 

The height and angle of note beams can be adjusted by dragging. Click on the leftmost side of 

the beam and you’ll get a handle that allows you to adjust the height by dragging. Click on the 

rightmost side of the beam and you will get a handle that allows you to adjust the angle. 

 

                        
 

                        
 

While this is of limited use on its own, this feature is useful when working with cross staff notes. 

We can select notes on a staff and use “Note Input->(Cross-staff Notes)Above” to move the 

notes to the staff above. Then the beam can be dragged to improve the appearance of the bar (and 

the upper staff rest is hidden by selecting and hiding it with “Home->Hide or Show->Hide or 

Show”. 

 

                      



4) Feathered beaming 

 

Feathered beams are accessible via the third panel on the keypad. 

 

                                         
 

Select the first note in the beam group, then apply the feathered beam command from the 

keypad. All the notes in the beam group must be of the same duration for this to work. 

 

 
 

 
 

  



BUILT IN SHAPES 

 

a) Boxes 

 

Boxes are line symbols in Sibelius. First select the notes you wish to box. Then pick “Notations-

>Lines->Box”. You will see a single line with a handle over the notes. Drag this handle down to 

expand the line into a box. You can also move the entire box by selecting an edge and dragging. 

 

                              
 

 
 

b) Thick line 

 

While there are many different types of lines in the “Notations->Lines” menu, a thick line 

doesn’t exist and needs to be created. To create a thick line, bring up the “Lines” dialog by 

selecting the dialog launcher button from “Notations->Lines” 

 



 
 

Find the existing line symbol (about 15 down) and select it. Click the “New…” button. You will 

be asked if you want to create a new line based on “Line”. Pick Yes. You will now see the line 

dialog. 

 



 
 

In the “Line” area of the dialog, change the “Width” from 0.16 to 1. Then select “Ok” and then 

“Close” on the prior dialog. The “Notations->Lines” gallery will now have a new element called 

“Line (2)” which is your thick line. It can be inserted, moved and resized as any other staff 

object. 

 

 
 

This technique can be used to make assorted other custom lines like thick dotted lines, or large 

arrows. 

 

c) Composite symbols 



Often the necessary notational symbols are already available in Sibelius, and just need to be 

combined. In this example I created a bracketed repeat by attaching the repeat symbol 

(“Notations->Symbols->Repeat bar”), left bracket (“Notations->Lines->Vertical bracket 2”) and 

right bracket (“Notations->Lines->Vertical bracket”) to a hidden note. The symbols are 

positioned with magnetic positioning off. 

 

 
 

EXTRA SYMBOLS VIA UNICODE 

 

In addition to the text and symbols normally available in Sibelius text objects (expression text, 

technique text etc.), Unicode symbols can also be used anywhere you can enter text. Two 

symbols I’ve used are the “infinity” symbol, and the “double tilde”. 

 

 
 

In the above example, both the infinity sign and the double tilde were entered as technique text. 

The double tilde font size was enlarged and the symbol moved (with magnetic layout off) to 

position it on the stem. 

 

On the PC, the infinity symbol can be typed by holding down the Alt key while typing 236 on 

the numeric keypad. The double tilde is typed by holding down the Alt key while typing 247 on 

the numeric keypad. 

 

The technique for entering Unicode code points varies from system to system. On a PC, Sibelius 

will only allow you to enter Unicode values that correspond to symbols in the current input code 

page (see below for further explanation). The text system inside Sibelius, however, seems to be 

capable of handling any Unicode code points, so it’s possible to copy and paste values from 

other programs. 

 

The website https://unicode-table.com is useful for the copy and paste technique. The site lets 

you browse the entire Unicode character space and copy characters to the clipboard for pasting 

into Sibelius. In this example, I attached Hebrew letters to notes using this system. 

 

https://unicode-table.com/


                                                        
 

Windows also has a program called “Character Map” which is located on the “Start” menu under 

the “Windows Accessories” category.  This program allows you to browse all the font glyphs 

that are available on your system. It also provides a copy mechanism for pasting into Sibelius. 

 

 
  

UNICODE TECHY STUFF 

 

Unicode characters (also known as code points) are multibyte values that allow for the 

representation of over a million different characters. There are two problems that arise when 

working with Unicode values, one of display and one of entry. 

 



On the display side, a code point can only appear on the screen if the display font has a glyph for 

that code point. Due to the vast number of code points, not all fonts will have glyphs for all code 

points. If the font in use does not have a glyph for the code point, you will either get a blank or a 

square box. In this case, selecting a different font may remedy the problem. 

 

On the input side, you need a method for entering code points. The entry mechanism will likely 

vary from application to application. Windows has a mechanism that provides access to a subset 

of the code points from the keyboard (the aforementioned Alt 236 and Alt 247 for infinity and 

tilde). These code pages are selected based on the language your computer is using. The 

currently active code page can be found by opening a command prompt and issuing the 

command “chcp” (mine is 437). For more information on the code pages and the characters 

immediately available, see 

 

https://www.fileformat.info/info/charset/codepage.htm 

https://www.fileformat.info/info/charset/IBM437/list.htm 

 

 

IMPORTING GRAPHICS 

 

Importing graphics is the ultimate notational Swiss Army Knife. When all else fails, you can 

draw it and import it. Sibelius allows you to resize and rotate imported graphics, making it an 

effective mechanism for more involved notation issues. 

 

The key to getting attractive imported graphics is to use a vector graphics program that creates 

“.svg” files. Vector graphics will rotate and scale inside Sibelius without becoming jagged or 

pixelated. There are many free and commercial programs that create vector graphics. My favorite 

free application is Inkscape. 

 

https://inkscape.org 

 

In this example I started by creating a sine wave shape in Inkscape, saved it as “triple curve.svg”. 

 

https://www.fileformat.info/info/charset/IBM437/list.htm
https://inkscape.org/


 
 

Then I select the notes where I’d like the curve and import it via “File->Graphic”. When it first 

appears it will likely be poorly positioned and the wrong size. 

 

 
 

The selection box surrounding the graphic has handles which allow you to resize, position, and 

rotate the graphic. The handles along the edge resize the graphic. The round handle in the middle 

(hard to see) allows you to move the graphic. The square handle just above the center allows you 

to rotate the graphic. Use the handles to position and size the graphic as appropriate. 

 



 
 

FREE FORM NOTE PLACEMENT 

 

It’s possible to lay out notes without regard to a time signature. The general technique here is to 

think in terms of the physical layout, based on a hypothetical rhythm or time signature. Then use 

various Sibelius tools for altering the notes visually.  

 

There are a few “rules of thumb” that I’ve found useful when doing free form note layout. 

 

a) Since laying out notes in this fashion is primarily a visual construct, you’ll get better results if 

you work in one of the page view modes instead of panorama mode. 

b) Though somewhat more tedious, horizontal movement of notes using the X offset in the object 

Inspector is more reliable than simply dragging the note. Dragging the note often causes 

unwanted movement in the surrounding notes. 

c) Hidden time signatures, notes, and rests are your friends. 

 

Example 1: A single staff with a bunch of notes 

 

If your music is comprised of only a single staff, then layout is somewhat easier. You needn’t 

worry that positioning tricks will affect the other staves. Let’s look at how you could construct 

this: 

 

 
 

This segment of music spans the width of the page, has no time signature and no barline. 

 

Since the music consists only of filled black noteheads, you can pretend that you are dealing with 

quarter notes, add it all up, and start with a time signature of 23/4. Set the time signature of the 

bar to 23/4, then enter the notes (as quarter notes) and the rests. You should have something that 

looks like this: 

 



 
 

Select the barline between the 23/4 and 4/4 measure and pick “Layout->System Break”. This 

will force the 23/4 measure to span the system (width of the page). 

 

Make the barline at the end of the 23/4 invisible (“Notations->Barline->Invisible”). 

 

Select the time signatures and hide them (“Home->Hide or Show->Hide or Show” or Ctrl-Shft-

H). 

 

Make all the notes stemless by selecting the measure and “Notations->Type(Noteheads)-

>Stemless” or Alt-Shift- 8. 

 

Add the parenthesis to the relevant noteheads (keypad page 2). 

 

Your music should now look like this: 

 

 
 

The notehead positioning is close, but not exactly what we want. The first and last notes should 

be closer to the edges. The first run of noteheads should be more spread out. The final run should 

be closer together. In this single staff case you can try and do some of the horizontal positioning 

by dragging notes, but you may find that unexpected things happen to surrounding noteheads. 

Often dragging a notehead does not move it, but moves the neighboring noteheads instead. 

Though somewhat tedious, using the X offset in the Inspector dialog gives reliable and expected 

results. 

 

Finally, add the other assorted objects (dynamics, slurs, hairpins etc.). Some of these may have to 

be positioned manually since applying X offset values to noteheads causes some problems with 

the ornament positioning. 

 

Example 2: Free form notes against a strict rhythm 

 



 
 

If you consider this from a physical layout perspective, the stop staff in the first bar is similar to a 

septuplet. The second bar, a nonuplet. That is exactly what we’ll do. Enter the notes as septuplets 

and nonuplets, then hide the unnecessary visual elements. 

 

We start like this: 

 

 
 

Select the tuplet symbols and hide them via “Home->Hide or Show->Hide or Show” (Ctrl-Shift-

H). 

 

Set the notes to stemless (“Notations->Type(Noteheads)->Stemless”), and add the boxes 

(“Notations->Lines->Box”). 

 

Example 3: Multiple staves with free form notes 

 

 
 



The strategy here is to take the maximum “beats” across all staves and use that as the time 

signature (which we then hide). If we think of the noteheads as quarter notes, the bottom staff 

can be thought of as having 31 beats, so we’ll use 31/4 as our hidden time signature. 

 

While the object Inspector dialog is good for fine tuning the spacing, the more coarse spacing is 

better done with hidden objects. Consider the third and fourth saves. In the third staff, the 

seventh notehead roughly spans eight noteheads in the corresponding position on the fourth staff. 

This layout can be achieved by following the third staff note with seven rests (or notes), which 

are then hidden. 

 

Before hiding elements and making fine adjustments, the layout might look something like this: 

 

 
 

 

As a larger example of what can be done in Sibelius, below is a link to a piece of my own called 

“Semiotics”. 

 

http://www.neilradisch.com/Semiotics%20-%20Full%20Score.pdf 
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